aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2010-10-20 14:50:50 -0500
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-21 14:05:57 +0100
commitf1a209b142d2319d2594b051c01d9997184bfcb4 (patch)
treea5c6fb9678888fe3c94a5edd680258aef966b270 /meta/recipes-core/busybox
parent70c77123084d6ef579dae0efde1c1b454827e597 (diff)
downloadopenembedded-core-contrib-f1a209b142d2319d2594b051c01d9997184bfcb4.tar.gz
busybox/sysklogd: syslog.conf files
The format of the syslog.conf files is different between busybox and sysklogd. Use the alternatives method to ensure we get the correct config file for any specific configurations. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox.inc7
-rw-r--r--meta/recipes-core/busybox/busybox_1.16.2.bb2
2 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index b8c009c1d3..24f9120a22 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -19,7 +19,7 @@ INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
INITSCRIPT_NAME_${PN} = "syslog"
-CONFFILES_${PN} = "${sysconfdir}/syslog.conf"
+CONFFILES_${PN} = "${sysconfdir}/syslog.conf.${PN}"
# This disables the syslog startup links in slugos (see slugos-init)
INITSCRIPT_PARAMS_${PN}_slugos = "start 20 ."
@@ -54,7 +54,7 @@ do_install () {
test -h ${D}/busybox${base_bindir}/sh && mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/
install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/syslog.${PN}
- install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/
+ install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/syslog.conf.${PN}
if grep "CONFIG_CROND=y" ${WORKDIR}/defconfig; then
# Move crond back to /usr/sbin/crond
install -d ${D}${sbindir}
@@ -109,6 +109,7 @@ pkg_postinst_${PN} () {
while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
update-alternatives --install ${sysconfdir}/init.d/syslog syslog-init syslog.${PN} 50
+ update-alternatives --install ${sysconfdir}/syslog.conf syslog-conf syslog.conf.${PN} 50
}
pkg_prerm_${PN} () {
@@ -149,4 +150,6 @@ pkg_prerm_${PN} () {
fi
update-alternatives --remove syslog-init syslog.${PN}
+ update-alternatives --remove syslog-conf syslog.conf.${PN}
}
+
diff --git a/meta/recipes-core/busybox/busybox_1.16.2.bb b/meta/recipes-core/busybox/busybox_1.16.2.bb
index 80dbeaba60..82a62711e5 100644
--- a/meta/recipes-core/busybox/busybox_1.16.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.16.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://udhcpscript.patch \