aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorYao Zhao <yao.zhao@windriver.com>2012-07-24 10:28:00 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:49 +0100
commitb37e1ea5f29d03efbe136ee7f4fa261a1936ac8f (patch)
tree7d77aaa79f0b68fb9ae168c9b39c8f36e26d5605 /meta/recipes-core/busybox
parentab498fa7a330d20639f3082cb1c05e92f37c5ced (diff)
downloadopenembedded-core-contrib-b37e1ea5f29d03efbe136ee7f4fa261a1936ac8f.tar.gz
busybox: fix the problem that mkfs.minix.tests fails on big endian platform
patch mkfs.minix.tests to have correct md5sum on big endian platform. Signed-off-by: Yao Zhao <yao.zhao@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox-1.19.4/busybox-mkfs-minix-tests_bigendian.patch34
-rw-r--r--meta/recipes-core/busybox/busybox_1.19.4.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-core/busybox/busybox-1.19.4/busybox-mkfs-minix-tests_bigendian.patch b/meta/recipes-core/busybox/busybox-1.19.4/busybox-mkfs-minix-tests_bigendian.patch
new file mode 100644
index 0000000000..089c5e039c
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox-1.19.4/busybox-mkfs-minix-tests_bigendian.patch
@@ -0,0 +1,34 @@
+patch mkfs.minix.tests to have correct md5sum on big endian platform
+
+Upstream-Status: Accepted, expected in next release
+
+Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
+
+diff --git a/testsuite/mkfs.minix.tests b/testsuite/mkfs.minix.tests
+index 8a33c16..7eecaf2 100755
+--- a/testsuite/mkfs.minix.tests
++++ b/testsuite/mkfs.minix.tests
+@@ -8,6 +8,14 @@
+
+ # testing "test name" "options" "expected result" "file input" "stdin"
+
++# '\n' produces 10 on little endian, but not on big endian
++cr=`echo | od -i | sed 's/.* //g;2d'`
++if [ x"$cr" = x"10" ]; then
++ hash=4f35f7afeba07d56055bed1f29ae20b7
++else
++ hash=5adbc1b3ccd20ca5d0ab5bc1e13ac3fc
++fi
++
+ testing "mkfs.minix" \
+ "dd if=/dev/zero of=input bs=1k count=1024 2>/dev/null; mkfs.minix input; md5sum <input" \
+ "352 inodes\n"\
+@@ -15,7 +23,7 @@ testing "mkfs.minix" \
+ "Firstdatazone=15 (15)\n"\
+ "Zonesize=1024\n"\
+ "Maxsize=268966912\n"\
+-"4f35f7afeba07d56055bed1f29ae20b7 -\n" \
++"$hash -\n" \
+ "" \
+ ""
+
diff --git a/meta/recipes-core/busybox/busybox_1.19.4.bb b/meta/recipes-core/busybox/busybox_1.19.4.bb
index 6e69d22598..cc97e2a853 100644
--- a/meta/recipes-core/busybox/busybox_1.19.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.19.4.bb
@@ -24,7 +24,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://mdev \
file://mdev.conf \
file://umount.busybox \
- file://defconfig"
+ file://defconfig \
+ file://busybox-mkfs-minix-tests_bigendian.patch"
SRC_URI[tarball.md5sum] = "9c0cae5a0379228e7b55e5b29528df8e"
SRC_URI[tarball.sha256sum] = "9b853406da61ffb59eb488495fe99cbb7fb3dd29a31307fcfa9cf070543710ee"