aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-08-06 10:50:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:06:10 +0100
commita022fb6b69388f28f3130e71125b64e4c154d504 (patch)
treeecefc95dd05ab6c21049e4ea28f316dfec90cc14 /meta/recipes-core/busybox
parent9c304eae0724474902fe2f3150adc6af115af9ba (diff)
downloadopenembedded-core-contrib-a022fb6b69388f28f3130e71125b64e4c154d504.tar.gz
busybox: fix du-k-works test case
[YOCTO #2896] The du-k-works test seems to assume that du -k on a directory with two files totaling 80 kilobytes should report either 80k or 88k. In ext4 filesystm however, both busybox' du -k and coreutils' du -k reports a size of 84k which causes the test to fail. Intergrate the patch from: http://git.busybox.net/busybox/commit/?id=a5ee090e8651692545514a81a16c6cde3a2dc577 Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox-1.19.4/fix-for-spurious-testsuite-failure.patch27
-rw-r--r--meta/recipes-core/busybox/busybox_1.19.4.bb5
2 files changed, 30 insertions, 2 deletions
diff --git a/meta/recipes-core/busybox/busybox-1.19.4/fix-for-spurious-testsuite-failure.patch b/meta/recipes-core/busybox/busybox-1.19.4/fix-for-spurious-testsuite-failure.patch
new file mode 100644
index 0000000000..b75eaacd29
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox-1.19.4/fix-for-spurious-testsuite-failure.patch
@@ -0,0 +1,27 @@
+Backport the patch from:
+http://git.busybox.net/busybox/commit/?id=a5ee090e8651692545514a81a16c6cde3a2dc577
+
+From a5ee090e8651692545514a81a16c6cde3a2dc577 Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Thu, 10 May 2012 19:26:37 +0200
+Subject: [PATCH] fix for spurious testsuite failure
+
+Upstream-Status: Backport
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ testsuite/du/du-k-works | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/testsuite/du/du-k-works b/testsuite/du/du-k-works
+index 229a948..36dcaa8 100644
+--- a/testsuite/du/du-k-works
++++ b/testsuite/du/du-k-works
+@@ -3,4 +3,5 @@ cd du.testdir
+ dd if=/dev/zero of=file1 bs=1k count=64 2>/dev/null
+ dd if=/dev/zero of=file2 bs=1k count=16 2>/dev/null
+ test x"`busybox du -k .`" = x"80 ." \
++ -o x"`busybox du -k .`" = x"84 ." \
+ -o x"`busybox du -k .`" = x"88 ."
+--
+1.7.4.1
+
diff --git a/meta/recipes-core/busybox/busybox_1.19.4.bb b/meta/recipes-core/busybox/busybox_1.19.4.bb
index ced50c55da..2e262ca481 100644
--- a/meta/recipes-core/busybox/busybox_1.19.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.19.4.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r12"
+PR = "r13"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://B921600.patch \
@@ -24,7 +24,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://mdev.conf \
file://umount.busybox \
file://defconfig \
- file://busybox-mkfs-minix-tests_bigendian.patch"
+ file://busybox-mkfs-minix-tests_bigendian.patch \
+ file://fix-for-spurious-testsuite-failure.patch"
SRC_URI[tarball.md5sum] = "9c0cae5a0379228e7b55e5b29528df8e"
SRC_URI[tarball.sha256sum] = "9b853406da61ffb59eb488495fe99cbb7fb3dd29a31307fcfa9cf070543710ee"