aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-04-25 15:44:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-01 11:55:43 +0100
commit2aa0540515efc15957101e24224b425ee00446d9 (patch)
tree9d0996fa7823b27a10b191eef575aef872ac06ec /meta/recipes-core/busybox
parentd478424fbe01942577ab541174df191528556554 (diff)
downloadopenembedded-core-contrib-2aa0540515efc15957101e24224b425ee00446d9.tar.gz
busybox: Pass HOST_CC_ARCH through CONFIG_EXTRA_CFLAGS
The -mabi option is part of HOST_CC_ARCH which does not appear in CFLAGS. This is for completeness since compiler already defaults to n64 it wont matter that much Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox.inc2
-rw-r--r--meta/recipes-core/busybox/busybox_1.19.4.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index ec76ad2902..1613878c3f 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -86,7 +86,7 @@ python () {
d.setVar('configmangle_append',
"/^### CROSS$/a\\\n%s\n" %
("\\n".join(["CONFIG_CROSS_COMPILER_PREFIX=\"${TARGET_PREFIX}\"",
- "CONFIG_EXTRA_CFLAGS=\"${CFLAGS}\""
+ "CONFIG_EXTRA_CFLAGS=\"${CFLAGS}\" \"${HOST_CC_ARCH}\""
])
))
}
diff --git a/meta/recipes-core/busybox/busybox_1.19.4.bb b/meta/recipes-core/busybox/busybox_1.19.4.bb
index ad8297ec94..2d4e96106c 100644
--- a/meta/recipes-core/busybox/busybox_1.19.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.19.4.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://udhcpscript.patch \