aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-12 14:59:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-12 15:12:15 +0100
commit01e372559052aa348ceced07540fdb774d292c65 (patch)
tree6ca811ea7729b20ae80545c46040ab2fbd38c0f0 /meta/recipes-core/busybox
parent50fdf562ce5c41782ff1bdea43a20e769e61eb92 (diff)
downloadopenembedded-core-contrib-01e372559052aa348ceced07540fdb774d292c65.tar.gz
busybox: fix missing features due to lack of variable expansion
Expand DISTRO_FEATURES and MACHINE_FEATURES fully so that any inner variable references (such as DISTRO_FEATURES_LIBC) are expanded properly. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox.inc4
-rw-r--r--meta/recipes-core/busybox/busybox_1.18.4.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index 1334d06964..c51cf6a124 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -47,8 +47,8 @@ def busybox_cfg(feature, features, tokens, cnf, rem):
# Map distro and machine features to config settings
def features_to_busybox_settings(d):
cnf, rem = ([], [])
- distro_features = bb.data.getVar('DISTRO_FEATURES', d).split()
- machine_features = bb.data.getVar('MACHINE_FEATURES', d).split()
+ distro_features = bb.data.getVar('DISTRO_FEATURES', d, True).split()
+ machine_features = bb.data.getVar('MACHINE_FEATURES', d, True).split()
busybox_cfg('ipv6', distro_features, 'CONFIG_FEATURE_IPV6', cnf, rem)
busybox_cfg('largefile', distro_features, 'CONFIG_LFS', cnf, rem)
busybox_cfg('largefile', distro_features, 'CONFIG_FDISK_SUPPORT_LARGE_DISKS', cnf, rem)
diff --git a/meta/recipes-core/busybox/busybox_1.18.4.bb b/meta/recipes-core/busybox/busybox_1.18.4.bb
index 5883cc65cf..9d3d5b138e 100644
--- a/meta/recipes-core/busybox/busybox_1.18.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.18.4.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r5"
+PR = "r6"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://udhcpscript.patch \