aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-08-24 13:26:17 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-25 14:43:01 +0100
commita8b1081791af60873c6fd26cbf298cfe1886f97d (patch)
tree23e370add6ac8cac9f58b2ad9b3a06a540e1febc /meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
parentbab34e5fa734a98cb5199db4ebc95a6634a38431 (diff)
downloadopenembedded-core-contrib-a8b1081791af60873c6fd26cbf298cfe1886f97d.tar.gz
base-passwd: upgrade to 3.5.26
The S variable is now the default one. Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/base-passwd/base-passwd_3.5.26.bb')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.26.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
new file mode 100644
index 0000000000..2073b3fa4a
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
@@ -0,0 +1,92 @@
+SUMMARY = "Base system master password/group files."
+DESCRIPTION = "The master copies of the user database files (/etc/passwd and /etc/group). The update-passwd tool is also provided to keep the system databases synchronized with these master files."
+SECTION = "base"
+PR = "r0"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_${PV}.tar.gz \
+ file://nobash.patch \
+ file://root-home.patch"
+
+SRC_URI[md5sum] = "74245e5c21dc74d9675c77cd8dfa02e6"
+SRC_URI[sha256sum] = "258a78317aa563143d10375c6e1e63a60898e503887f00fffd70b6b297c1b429"
+
+inherit autotools
+
+SSTATEPOSTINSTFUNCS += "base_passwd_sstate_postinst"
+
+do_install () {
+ install -d -m 755 ${D}${sbindir}
+ install -o root -g root -p -m 755 update-passwd ${D}${sbindir}/
+ install -d -m 755 ${D}${mandir}/man8 ${D}${mandir}/pl/man8
+ install -p -m 644 man/update-passwd.8 ${D}${mandir}/man8/
+ install -p -m 644 man/update-passwd.pl.8 \
+ ${D}${mandir}/pl/man8/update-passwd.8
+ gzip -9 ${D}${mandir}/man8/* ${D}${mandir}/pl/man8/*
+ install -d -m 755 ${D}${datadir}/base-passwd
+ install -o root -g root -p -m 644 passwd.master ${D}${datadir}/base-passwd/
+ install -o root -g root -p -m 644 group.master ${D}${datadir}/base-passwd/
+
+ install -d -m 755 ${D}${docdir}/${BPN}
+ install -p -m 644 debian/changelog ${D}${docdir}/${BPN}/
+ gzip -9 ${D}${docdir}/${BPN}/*
+ install -p -m 644 README ${D}${docdir}/${BPN}/
+ install -p -m 644 debian/copyright ${D}${docdir}/${BPN}/
+}
+
+base_passwd_sstate_postinst() {
+ if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+ then
+ # Staging does not copy ${sysconfdir} files into the
+ # target sysroot, so we need to do so manually. We
+ # put these files in the target sysroot so they can
+ # be used by recipes which use custom user/group
+ # permissions.
+ install -d -m 755 ${STAGING_DIR_TARGET}${sysconfdir}
+ install -p -m 644 ${STAGING_DIR_TARGET}${datadir}/base-passwd/passwd.master ${STAGING_DIR_TARGET}${sysconfdir}/passwd
+ install -p -m 644 ${STAGING_DIR_TARGET}${datadir}/base-passwd/group.master ${STAGING_DIR_TARGET}${sysconfdir}/group
+ fi
+}
+
+python populate_packages_prepend() {
+ # Add in the preinst function for ${PN}
+ # We have to do this here as prior to this, passwd/group.master
+ # would be unavailable. We need to create these files at preinst
+ # time before the files from the package may be available, hence
+ # storing the data from the files in the preinst directly.
+
+ f = open(d.expand("${STAGING_DATADIR}/base-passwd/passwd.master"), 'r')
+ passwd = "".join(f.readlines())
+ f.close()
+ f = open(d.expand("${STAGING_DATADIR}/base-passwd/group.master"), 'r')
+ group = "".join(f.readlines())
+ f.close()
+
+ preinst = """#!/bin/sh
+if [ ! -e $D${sysconfdir}/passwd ]; then
+\tcat << EOF > $D${sysconfdir}/passwd
+""" + passwd + """EOF
+fi
+if [ ! -e $D${sysconfdir}/group ]; then
+\tcat << EOF > $D${sysconfdir}/group
+""" + group + """EOF
+fi
+"""
+ d.setVar('pkg_preinst_${PN}', preinst)
+}
+
+addtask do_package after do_populate_sysroot
+
+ALLOW_EMPTY_${PN} = "1"
+
+PACKAGES =+ "${PN}-update"
+FILES_${PN}-update = "${sbindir}/* ${datadir}/${PN}"
+
+pkg_postinst_${PN}-update () {
+#!/bin/sh
+if [ -n "$D" ]; then
+ exit 0
+fi
+${sbindir}/update-passwd
+}