aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files/base-files_3.0.14.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-08-01 13:25:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 11:36:22 +0100
commit41688279cba3a5afc4fdc65fd245b9bb6ada695e (patch)
tree08d8aca3176c80dd6d75eb7379e6b971488c5a1a /meta/recipes-core/base-files/base-files_3.0.14.bb
parent4af10fe67a31368163bb5d468ee2c5a85ce0fff3 (diff)
downloadopenembedded-core-contrib-41688279cba3a5afc4fdc65fd245b9bb6ada695e.tar.gz
base-files: fix handling of resize
The current handling of resize is incorrect. Using `resize > /dev/null 2>&1 && resize > /dev/null' will cause the second resize command to not execute because 'resize > /dev/null 2>&1' will fail for resize utility from busybox. What we really should do is just to check whether ${bindir}/resize is executable and execute it if so. Using '-x' is sufficient. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files/base-files_3.0.14.bb')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 1c0863b1c7..05c0562661 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -121,6 +121,7 @@ do_install () {
install -m 0644 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/profile
sed -i 's#ROOTHOME#${ROOT_HOME}#' ${D}${sysconfdir}/profile
+ sed -i 's#@BINDIR@#${bindir}#g' ${D}${sysconfdir}/profile
install -m 0644 ${WORKDIR}/shells ${D}${sysconfdir}/shells
install -m 0755 ${WORKDIR}/share/dot.profile ${D}${sysconfdir}/skel/.profile
install -m 0755 ${WORKDIR}/share/dot.bashrc ${D}${sysconfdir}/skel/.bashrc