aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files/base-files_3.0.14.bb
diff options
context:
space:
mode:
authorElizabeth Flanagan <elizabeth.flanagan@intel.com>2011-12-03 15:48:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-08 15:23:49 +0000
commit3083dd70b3a9fa01fcc3cf00373b05502505996e (patch)
tree85967d32dd9c02d410739d782b6a4e500a5e0702 /meta/recipes-core/base-files/base-files_3.0.14.bb
parent558b5043e1d5a36caff137093fd04abcf025af1c (diff)
downloadopenembedded-core-contrib-3083dd70b3a9fa01fcc3cf00373b05502505996e.tar.gz
OECore license fixes: meta/*
This is a quick audit of only the most obviously wrong licenses found within OECore. These fixes fall into four areas: - LICENSE field had incorrect format so that the parser choked - LICENSE field has a license with no version - LICENSE field was actually incorrect - LICENSE field has an imaginary license that didn't exist This fixes most of the LICENSE warnings thrown, along with my prior commit adding additional licenses to common-licenses and additional SPDXLICENSEMAP entries. HOWEVER..... there is much to be done on the license front. For a list of recipes with licenses that need obvious fixing see: https://wiki.yoctoproject.org/wiki/License_Audit That said, I would suggest another license audit as I've found enough inconsistencies. A good suggestion is when in doubt, look at how openSuse or Gentoo or Debian license the package. Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com>
Diffstat (limited to 'meta/recipes-core/base-files/base-files_3.0.14.bb')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb20
1 files changed, 8 insertions, 12 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 8f5313b652..eb40917eb5 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -1,9 +1,15 @@
SUMMARY = "Miscellaneous files for the base system."
DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system."
SECTION = "base"
-PR = "r69"
+PR = "r70"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f"
+# Removed all license related tasks in this recipe as license.bbclass
+# now deals with this. In order to get accurate licensing on to the image:
+# Set COPY_LIC_MANIFEST to just copy just the license.manifest to the image
+# For the manifest and the license text for each package:
+# Set COPY_LIC_MANIFEST and COPY_LIC_DIRS
+
SRC_URI = "file://rotation \
file://nsswitch.conf \
file://motd \
@@ -18,14 +24,8 @@ SRC_URI = "file://rotation \
file://usbd \
file://share/dot.bashrc \
file://share/dot.profile \
- file://licenses/BSD \
file://licenses/GPL-2 \
- file://licenses/GPL-3 \
- file://licenses/LGPL-2 \
- file://licenses/LGPL-2.1 \
- file://licenses/LGPL-3 \
- file://licenses/GFDL-1.2 \
- file://licenses/Artistic"
+ "
S = "${WORKDIR}"
INHIBIT_DEFAULT_DEPS = "1"
@@ -103,10 +103,6 @@ do_install () {
install -m 0644 ${WORKDIR}/host.conf ${D}${sysconfdir}/host.conf
install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
- for license in BSD GPL-2 LGPL-2 LGPL-2.1 Artistic GPL-3 LGPL-3 GFDL-1.2; do
- install -m 0644 ${WORKDIR}/licenses/$license ${D}${datadir}/common-licenses/
- done
-
ln -sf /proc/mounts ${D}${sysconfdir}/mtab
}