aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-07-28 13:39:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-29 15:22:25 +0100
commit0bda7fda8ce11b9b8c4c69aee1afbda30c3eadd5 (patch)
tree6508308efeddb5d5a83aae8a6af87225d8e15682 /meta/recipes-connectivity
parent061c17ff22f4df573bccbf4b66f2fdf5501c3617 (diff)
downloadopenembedded-core-contrib-0bda7fda8ce11b9b8c4c69aee1afbda30c3eadd5.tar.gz
openssl_1.0: squash whitespace in CC_INFO
Squash whitespace in CC_INFO to avoid recipe whitespace changes to CFLAG affecting the final openssl binaries (the value of CC_INFO gets embedded in libcrypto, via buildinf.h). (From OE-Core rev: 2227c51896d4399daac9d85f40d7510b7c8ae03f) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2o.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
index bbce14fe6b..f5d327475b 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
@@ -211,7 +211,7 @@ do_compile () {
do_compile_class-target () {
sed -i 's/\((OPENSSL=\)".*"/\1"openssl"/' Makefile
oe_runmake depend
- cc_sanitized=`echo "${CC} ${CFLAG}" | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' -e 's|${DEBUG_PREFIX_MAP}||g'`
+ cc_sanitized=$(echo "${CC} ${CFLAG}" | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' -e 's|${DEBUG_PREFIX_MAP}||g' -e 's/[ \t]\+/ /g')
oe_runmake CC_INFO="$cc_sanitized"
}