aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-04 10:36:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-05 11:54:46 +0100
commitf4bfa18e15776f667f22c0afaaf9d8dedd02c43d (patch)
treea2a9a5548ae31fa1eb3b598edca8cc498fdef357 /meta/recipes-connectivity
parent31e12439ec7db3e50bfdc2c86d074891e3231ba5 (diff)
downloadopenembedded-core-contrib-f4bfa18e15776f667f22c0afaaf9d8dedd02c43d.tar.gz
gypsy_0.8.bb: Fix build with gcc 4.6
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch16
-rw-r--r--meta/recipes-connectivity/gypsy/gypsy_0.8.bb7
2 files changed, 20 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch b/meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch
new file mode 100644
index 0000000000..d826970880
--- /dev/null
+++ b/meta/recipes-connectivity/gypsy/files/fix-unused-but-set-variable-warning.patch
@@ -0,0 +1,16 @@
+Index: gypsy-0.8/gypsy/gypsy-time.c
+===================================================================
+--- gypsy-0.8.orig/gypsy/gypsy-time.c
++++ gypsy-0.8/gypsy/gypsy-time.c
+@@ -156,10 +156,10 @@ get_property (GObject *object,
+ GParamSpec *pspec)
+ {
+ GypsyTimePrivate *priv;
+-
+ priv = GET_PRIVATE (object);
+ switch (prop_id) {
+ case PROP_PATH:
++ g_value_set_string (value, priv->object_path);
+ break;
+
+ default:
diff --git a/meta/recipes-connectivity/gypsy/gypsy_0.8.bb b/meta/recipes-connectivity/gypsy/gypsy_0.8.bb
index ab7f6b086a..f3d3fa7c28 100644
--- a/meta/recipes-connectivity/gypsy/gypsy_0.8.bb
+++ b/meta/recipes-connectivity/gypsy/gypsy_0.8.bb
@@ -13,9 +13,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
SECTION = "x11"
DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt"
-SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz"
-
-PR = "r0"
+SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \
+ file://fix-unused-but-set-variable-warning.patch \
+ "
+PR = "r1"
inherit autotools pkgconfig