aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-10-27 16:15:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-02 08:21:01 +0000
commit8139ac9284031e00d6b268210b04b57670d9268a (patch)
tree0395e7de8a58cfbab9236aa1366aad797d02eb44 /meta/recipes-connectivity
parent6823a32035de5d0bcd82a3b41a6ad536aaddbc58 (diff)
downloadopenembedded-core-contrib-8139ac9284031e00d6b268210b04b57670d9268a.tar.gz
connman: Use useradd to add the xuser for DBus
Connmand needs to start as the xuser as defined in the dbus configuration and needs to share this with rootless X. Since it's possible for connmand to run on a sytem without rootless X we still need to create the user here. Useradd will fail gracefully if the user already exists. Fixes: [YOCTO #1699] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc7
-rw-r--r--meta/recipes-connectivity/connman/connman_0.75.bb2
2 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index ae1b725e7d..480b59cb5c 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -18,7 +18,12 @@ DEPENDS = "libgdbus dbus glib-2.0 iptables"
INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "start 05 5 2 3 . stop 22 0 1 6 ."
-inherit autotools pkgconfig update-rc.d
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system --no-create-home \
+ --shell /bin/false --groups video,tty,audio \
+ --user-group xuser"
+
+inherit autotools pkgconfig update-rc.d useradd
do_install_append() {
install -d ${D}${sysconfdir}/init.d/
diff --git a/meta/recipes-connectivity/connman/connman_0.75.bb b/meta/recipes-connectivity/connman/connman_0.75.bb
index 8a02753f04..78f2199d0c 100644
--- a/meta/recipes-connectivity/connman/connman_0.75.bb
+++ b/meta/recipes-connectivity/connman/connman_0.75.bb
@@ -1,5 +1,5 @@
require connman.inc
-PR = "r2"
+PR = "r3"
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \