aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-12-17 11:36:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-19 09:25:31 +0000
commit507bd087375d2c0ac84e0c51196e2fe718aed339 (patch)
tree82d39c7555fc0d17dbb5d92b9ed374fb7ea3d401 /meta/recipes-connectivity
parent7da58c6fdaa8feef5ee5637dfb74912e7e4f5394 (diff)
downloadopenembedded-core-contrib-507bd087375d2c0ac84e0c51196e2fe718aed339.tar.gz
connman: disable 'alg-test' building
'alg-test' requires 'linux/if_alg.h' header enforcing a dependency on linux-libc-headers 2.6.39 or newer. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc8
-rw-r--r--meta/recipes-connectivity/connman/connman/disable_alg-test.patch46
-rw-r--r--meta/recipes-connectivity/connman/connman_0.78.bb3
3 files changed, 48 insertions, 9 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index bb1b27990c..d1bf7cdd9f 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -49,14 +49,6 @@ USERADD_PARAM_${PN} = "--system --no-create-home \
inherit autotools pkgconfig update-rc.d useradd
-# alg-test doesn't build, so disable that and test
-# for if_alg.h as this header is only in 2.6.39
-do_configure_prepend() {
- sed -i 's:tools/alg-test ::g' Makefile.am
- sed -i 's:AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,::g;
- s:AC_MSG_ERROR(User-space algorithm header files are required))::g' configure.ac
-}
-
do_compile_append() {
sed -i -e s:deny:allow:g src/connman-dbus.conf
}
diff --git a/meta/recipes-connectivity/connman/connman/disable_alg-test.patch b/meta/recipes-connectivity/connman/connman/disable_alg-test.patch
new file mode 100644
index 0000000000..c231d75c4f
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/disable_alg-test.patch
@@ -0,0 +1,46 @@
+From b9a20c8eb61b600ced284646a1bea588fdd8a5ea Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Fri, 16 Dec 2011 19:31:59 -0200
+Subject: [PATCH] Disable building of alg-test
+
+alg-test utility depends on linux/if_alg.h header that is only
+available on kernels >= 2.6.39.
+
+Upstream Status: Inappropriate [configuration]
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ Makefile.am | 2 +-
+ configure.ac | 3 ---
+ 2 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index d5a76f9..d42a766 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -144,7 +144,7 @@ noinst_PROGRAMS += tools/wispr tools/supplicant-test \
+ tools/dbus-test tools/polkit-test \
+ tools/iptables-test tools/tap-test tools/wpad-test \
+ tools/stats-tool tools/private-network-test \
+- tools/alg-test unit/test-session
++ unit/test-session
+
+ tools_wispr_SOURCES = $(gweb_sources) tools/wispr.c
+ tools_wispr_LDADD = @GLIB_LIBS@ @GNUTLS_LIBS@ -lresolv
+diff --git a/configure.ac b/configure.ac
+index f63fea8..67bfe85 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -437,9 +437,6 @@ if (test "${enable_tools}" = "yes"); then
+ AC_MSG_ERROR(GnuTLS library is required))
+ AC_SUBST(GNUTLS_CFLAGS)
+ AC_SUBST(GNUTLS_LIBS)
+-
+- AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,
+- AC_MSG_ERROR(User-space algorithm header files are required))
+ fi
+ AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")
+
+--
+1.7.7.3
+
diff --git a/meta/recipes-connectivity/connman/connman_0.78.bb b/meta/recipes-connectivity/connman/connman_0.78.bb
index 74c102b852..c73cad92f1 100644
--- a/meta/recipes-connectivity/connman/connman_0.78.bb
+++ b/meta/recipes-connectivity/connman/connman_0.78.bb
@@ -1,11 +1,12 @@
require connman.inc
-PR = "r5"
+PR = "r6"
# 0.78 tag
SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"
SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
file://add_xuser_dbus_permission.patch \
file://ethernet_default.patch \
+ file://disable_alg-test.patch \
file://connman"
S = "${WORKDIR}/git"