aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-21 22:00:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:35:51 +0100
commit39481b72644d2779bb681bb2dba8db5ba1a3d18d (patch)
tree0c1a908210538291f0c50cb901719b075f9f4590 /meta/recipes-connectivity
parent9f3401eb2c7ee6a4cf9c1b0cdeb61c8c0fdd2301 (diff)
downloadopenembedded-core-contrib-39481b72644d2779bb681bb2dba8db5ba1a3d18d.tar.gz
iproute2: Fix build error due to missing stdint.h> include
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch32
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch
new file mode 100644
index 0000000000..eb0c0abbab
--- /dev/null
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-include-stdint.h-explicitly-for-UINT16_MAX.patch
@@ -0,0 +1,32 @@
+From 3c885d87befc706bb923933b9819de6fe2de897e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 20 May 2017 14:03:19 -0700
+Subject: [PATCH] include stdint.h explicitly for UINT16_MAX)
+
+Fixes
+| tc_core.c:190:29: error: 'UINT16_MAX' undeclared (first use in this function); did you mean '__INT16_MAX__'?
+| if ((sz >> s->size_log) > UINT16_MAX) {
+| ^~~~~~~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ tc/tc_core.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tc/tc_core.c b/tc/tc_core.c
+index 7bbe0d7..821b741 100644
+--- a/tc/tc_core.c
++++ b/tc/tc_core.c
+@@ -12,6 +12,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <unistd.h>
+ #include <syslog.h>
+ #include <fcntl.h>
+--
+2.13.0
+
diff --git a/meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb b/meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb
index a050e8737e..063d467440 100644
--- a/meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb
+++ b/meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb
@@ -4,6 +4,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
file://configure-cross.patch \
file://0001-iproute2-de-bash-scripts.patch \
file://0001-libc-compat.h-add-musl-workaround.patch \
+ file://0001-include-stdint.h-explicitly-for-UINT16_MAX.patch \
"
SRC_URI[md5sum] = "b94a2b0edefaeac124dc8f5d006931b9"