aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorMikko Rapeli <mikko.rapeli@bmw.de>2018-06-13 10:15:56 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 10:59:33 +0100
commit70470dfa88338cae06670195bb7009cb13098ac2 (patch)
tree41ebfaceecc6a78f92dbc2d69a1ce28e3005de1b /meta/recipes-connectivity
parent5368bc5d0d3606198b93e877bcafcd77bb5f4fd1 (diff)
downloadopenembedded-core-contrib-70470dfa88338cae06670195bb7009cb13098ac2.tar.gz
openssh: add nativesdk support
And use bitbake variables for install paths to fix nativesdk-openssh compilation. Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.7p1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_7.7p1.bb b/meta/recipes-connectivity/openssh/openssh_7.7p1.bb
index 6b67782695..b3da5f6761 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.7p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.7p1.bb
@@ -52,9 +52,9 @@ EXTRA_AUTORECONF += "--exclude=aclocal"
EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
--without-zlib-version-check \
- --with-privsep-path=/var/run/sshd \
+ --with-privsep-path=${localstatedir}/run/sshd \
--sysconfdir=${sysconfdir}/ssh \
- --with-xauth=/usr/bin/xauth \
+ --with-xauth=${bindir}/xauth \
--disable-strip \
"
@@ -160,3 +160,5 @@ CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
ALTERNATIVE_PRIORITY = "90"
ALTERNATIVE_${PN}-scp = "scp"
ALTERNATIVE_${PN}-ssh = "ssh"
+
+BBCLASSEXTEND += "nativesdk"