aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-07-06 12:05:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-07 11:01:05 +0100
commit2a30a9ecab6465892698f7fc9d14a430d8a26f0c (patch)
tree5b5c47409e8c278be292c47c4dd5d7c4e7a7474f /meta/recipes-connectivity
parentb3f148333515efdb746b78c57d62cfbf3321b21e (diff)
downloadopenembedded-core-contrib-2a30a9ecab6465892698f7fc9d14a430d8a26f0c.tar.gz
openssl_1.1: avoid using += with an over-ride
Using += with an over-ride can be a source of confusion so try to avoid the construct in core recipes. The current usage is incorrect and prevents the aarch64 and musl specific config options from being active together. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.0h.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
index 29f83a31a2..64b8a997d0 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
@@ -126,12 +126,12 @@ do_configure () {
#| engines/afalg/e_afalg.c:110:20: error: '__NR_eventfd' undeclared (first use in this function)
#| return syscall(__NR_eventfd, n);
#| ^~~~~~~~~~~~
-EXTRA_OECONF_aarch64 += "no-afalgeng"
+EXTRA_OECONF_append_aarch64 = " no-afalgeng"
#| ./libcrypto.so: undefined reference to `getcontext'
#| ./libcrypto.so: undefined reference to `setcontext'
#| ./libcrypto.so: undefined reference to `makecontext'
-EXTRA_OECONF_libc-musl += "-DOPENSSL_NO_ASYNC"
+EXTRA_OECONF_append_libc-musl = " -DOPENSSL_NO_ASYNC"
do_install () {
oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install