summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-01 22:50:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-02 15:15:26 +0100
commitf25dd633fffe6560f191526d1869e657e129bad9 (patch)
treed49fa26293f1dca91ca1b00235b19b6579784379 /meta/recipes-connectivity
parent86fec41b1e809d1a2fa2feadc26d29020df53d39 (diff)
downloadopenembedded-core-contrib-f25dd633fffe6560f191526d1869e657e129bad9.tar.gz
recipes: Update S = WORKDIR recipes to use ${S} correctly
Where recipes use S = ${WORKDIR}, ensure they are referencing ${S} correctly to access files as soon we want to stop doing this in WORKDIR at which point they would break unless corrected. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
index 099c58bfc7..0c3085d3a8 100644
--- a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
+++ b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
@@ -15,10 +15,10 @@ S = "${WORKDIR}"
do_install() {
install -d ${D}${sysconfdir}/ppp/peers
- install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
+ install -m 0644 ${S}/host-peer ${D}${sysconfdir}/ppp/peers/host
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
+ install -m 0755 ${S}/ppp-dialin ${D}${sbindir}
}
USERADD_PACKAGES = "${PN}"