summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-03-01 15:05:59 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-03 15:38:08 +0000
commit914e1520bf9c45e14bce9993c9131a2c0702b9c9 (patch)
tree23df493c0e0ac9c3a0f6b8dcafd3063ab516ddd1 /meta/recipes-connectivity/openssl
parente11e4ebb521882ec64296e65b901ff1d9bccc23a (diff)
downloadopenembedded-core-contrib-914e1520bf9c45e14bce9993c9131a2c0702b9c9.tar.gz
openssl10: Fix mutliple include assumptions for des.h in opensslconf.h
The fix is heavily based on Khem's previous fix for bn.h/BN_LLONG breakage: https://git.openembedded.org/openembedded-core/commit/?id=f787b0bb9b0626ddbf2ac94cb206c76716a3773d Signed-off-by: Denys Dmytriyenko <denys@ti.com> Cc: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl')
-rw-r--r--meta/recipes-connectivity/openssl/openssl10/0001-Fix-DES_LONG-breakage.patch35
-rw-r--r--meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl10/0001-Fix-DES_LONG-breakage.patch b/meta/recipes-connectivity/openssl/openssl10/0001-Fix-DES_LONG-breakage.patch
new file mode 100644
index 0000000000..7243fb417b
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl10/0001-Fix-DES_LONG-breakage.patch
@@ -0,0 +1,35 @@
+From 1aec49cc45e7cf5ebc059a77081ac3ea2a5aff7b Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Fri, 1 Mar 2019 13:14:56 -0500
+Subject: [PATCH] Fix DES_LONG breakage
+
+Mimic previous BN_LLONG fix by Khem Raj here. Re-use its description:
+
+opensslconf.h is defining DES_LONG only when included from des.h which
+is not robust at all, especially when include guards are used and
+multiple inclusions of a given header is not allowed. so lets take out
+the nesting constraint and add OPENSSL_SYS_UEFI constraint instead
+
+Upstream-Status: Inappropriate [ fixed differently with OpenSSL 1.1+ ]
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ crypto/opensslconf.h.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/crypto/opensslconf.h.in b/crypto/opensslconf.h.in
+index a10c10f..0147a4d 100644
+--- a/crypto/opensslconf.h.in
++++ b/crypto/opensslconf.h.in
+@@ -48,7 +48,7 @@
+ #endif
+ #endif
+
+-#if (defined(HEADER_NEW_DES_H) || defined(HEADER_DES_H)) && !defined(DES_LONG)
++#if !defined(OPENSSL_SYS_UEFI) && !defined(DES_LONG)
+ /* If this is set to 'unsigned int' on a DEC Alpha, this gives about a
+ * %20 speed up (longs are 8 bytes, int's are 4). */
+ #ifndef DES_LONG
+--
+2.7.4
+
diff --git a/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb b/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
index 88aefdea4f..eacdf8b86e 100644
--- a/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
+++ b/meta/recipes-connectivity/openssl/openssl10_1.0.2q.bb
@@ -41,6 +41,7 @@ SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \
file://0001-allow-manpages-to-be-disabled.patch \
file://0001-Fix-BN_LLONG-breakage.patch \
+ file://0001-Fix-DES_LONG-breakage.patch \
"
SRC_URI_append_class-target = " \