aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.0j.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-07-20 08:38:34 -0700
committerAndreas Oberritter <obi@opendreambox.org>2014-07-11 12:47:35 +0200
commit98c3f49024b8e8dab4ce1faaa68d6df94cd2e9cc (patch)
treec0a069127a1cdbd567efd90e25a4252627ac2337 /meta/recipes-connectivity/openssl/openssl_1.0.0j.bb
parent234adb630e407520110b8a8e06dc8f2a302cd491 (diff)
downloadopenembedded-core-contrib-98c3f49024b8e8dab4ce1faaa68d6df94cd2e9cc.tar.gz
openssl: upgrade to 1.0.0j
Addresses CVE-2012-2333 Fixes [YOCTO #2682] Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 57f45fca7b8e1c0cf98d295bc0fd8839799dfa86) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.0j.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.0j.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0j.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0j.bb
new file mode 100644
index 0000000000..7dac79cbad
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.0j.bb
@@ -0,0 +1,50 @@
+require openssl.inc
+
+# For target side versions of openssl enable support for OCF Linux driver
+# if they are available.
+DEPENDS += "ocf-linux"
+
+CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
+
+PR = "${INC_PR}.3"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
+
+export DIRS = "crypto ssl apps engines"
+export OE_LDFLAGS="${LDFLAGS}"
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://oe-ldflags.patch \
+ file://engines-install-in-libdir-ssl.patch \
+ file://openssl-fix-link.patch \
+ file://debian/version-script.patch \
+ file://debian/pic.patch \
+ file://debian/c_rehash-compat.patch \
+ file://debian/ca.patch \
+ file://debian/make-targets.patch \
+ file://debian/no-rpath.patch \
+ file://debian/man-dir.patch \
+ file://debian/man-section.patch \
+ file://debian/no-symbolic.patch \
+ file://debian/debian-targets.patch \
+ file://openssl_fix_for_x32.patch \
+ file://find.pl \
+ "
+
+SRC_URI[md5sum] = "cbe4ac0d8f598680f68a951e04b0996b"
+SRC_URI[sha256sum] = "626fb8fcb3eb7e966edbe71553ff993d137f6e8a87b05051a3695e621098b8af"
+
+PACKAGES =+ " \
+ ${PN}-engines \
+ ${PN}-engines-dbg \
+ "
+
+FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
+FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
+
+PARALLEL_MAKEINST = ""
+
+do_configure_prepend() {
+ cp ${WORKDIR}/find.pl ${S}/util/find.pl
+}