summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl10/shared-libs.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-08-28 12:23:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-04 11:03:56 +0100
commitdf15a4c914177024f1825aacb4701fd232e1dd58 (patch)
tree82e7f832e4fa30f388883afd553453217397e7f3 /meta/recipes-connectivity/openssl/openssl10/shared-libs.patch
parent352d1a4bfdb687bc0d14c74d76e538eeac88ab5d (diff)
downloadopenembedded-core-contrib-df15a4c914177024f1825aacb4701fd232e1dd58.tar.gz
openssl: rename openssl 1.0.x to openssl10 and make openssl 1.1.x the default version
I believe the time has come to do this: openssl 1.0 upstream support stops at the end of 2019, and we do not want a situation where a supported YP release contains an unsupported version of a critical security component. Openssl 1.0 can still be utilized by depending on 'openssl10' recipe. (From OE-Core rev: 876466145f2da93757ba3f92177d0f959f5fe975) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl10/shared-libs.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl10/shared-libs.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl10/shared-libs.patch b/meta/recipes-connectivity/openssl/openssl10/shared-libs.patch
new file mode 100644
index 0000000000..a7ca0a3078
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl10/shared-libs.patch
@@ -0,0 +1,41 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: openssl-1.0.1e/crypto/Makefile
+===================================================================
+--- openssl-1.0.1e.orig/crypto/Makefile
++++ openssl-1.0.1e/crypto/Makefile
+@@ -108,7 +108,7 @@ $(LIB): $(LIBOBJ)
+
+ shared: buildinf.h lib subdirs
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ libs:
+Index: openssl-1.0.1e/Makefile.org
+===================================================================
+--- openssl-1.0.1e.orig/Makefile.org
++++ openssl-1.0.1e/Makefile.org
+@@ -310,7 +310,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a fips_
+
+ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
++ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2; \
+ exit 1; \
+Index: openssl-1.0.1e/ssl/Makefile
+===================================================================
+--- openssl-1.0.1e.orig/ssl/Makefile
++++ openssl-1.0.1e/ssl/Makefile
+@@ -62,7 +62,7 @@ lib: $(LIBOBJ)
+
+ shared: lib
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ files: