aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-08-08 18:30:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-11 00:08:32 +0100
commitda1183f9fa5e06fbe66b5b31eb3313d5d35d11e3 (patch)
tree7de4d9a6021b04967865cb62b06082e00406d09b /meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch
parent0b0a716b243491f026cb7b15e8f546325d6fa760 (diff)
downloadopenembedded-core-contrib-da1183f9fa5e06fbe66b5b31eb3313d5d35d11e3.tar.gz
openssl: add a 1.1 version
Existing openssl 1.0 recipe is renamed to openssl10; it will continue to be provided for as long as upstream supports it (and there are still several recipes which do not work with openssl 1.1 due to API differences). A few files (such as openssl binary) are no longer installed by openssl 1.0, because they clash with openssl 1.1. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch b/meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch
new file mode 100644
index 0000000000..ef6d17934d
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl10/ptest-deps.patch
@@ -0,0 +1,34 @@
+Remove Makefile dependencies for test targets
+
+These are probably here because the executables aren't always built for
+other platforms (e.g. Windows); however we can safely assume they'll
+always be there. None of the other test targets have such dependencies
+and if we don't remove them, make tries to rebuild the executables and
+fails during run-ptest.
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+Index: openssl-1.0.2/test/Makefile
+===================================================================
+--- openssl-1.0.2.orig/test/Makefile
++++ openssl-1.0.2/test/Makefile
+@@ -330,7 +330,7 @@ test_cms: ../apps/openssl$(EXE_EXT) cms-
+ @echo "CMS consistency test"
+ $(PERL) cms-test.pl
+
+-test_srp: $(SRPTEST)$(EXE_EXT)
++test_srp:
+ @echo "Test SRP"
+ ../util/shlib_wrap.sh ./srptest
+
+@@ -342,7 +342,7 @@ test_v3name: $(V3NAMETEST)$(EXE_EXT)
+ @echo "Test X509v3_check_*"
+ ../util/shlib_wrap.sh ./$(V3NAMETEST)
+
+-test_heartbeat: $(HEARTBEATTEST)$(EXE_EXT)
++test_heartbeat:
+ ../util/shlib_wrap.sh ./$(HEARTBEATTEST)
+
+ test_constant_time: $(CONSTTIMETEST)$(EXE_EXT)