aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-02-02 10:16:25 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-02 15:42:12 -0800
commitd58903b22aa879484a5eaa01efad5c031ea485fa (patch)
tree8de542d4098200396c3673c639377d76e9150020 /meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch
parent263c39e624d6c8681e716d26718ce7502de8ae6d (diff)
downloadopenembedded-core-contrib-d58903b22aa879484a5eaa01efad5c031ea485fa.tar.gz
openssl: Update to 0.9.8t (gplv2)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch b/meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch
new file mode 100644
index 0000000000..19de11243a
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-0.9.8t/shared-libs.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Inappropriate [configuration]
+
+diff --git a/Makefile.org b/Makefile.org
+index e87d623..25ff367 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -355,7 +355,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+ if [ "$(FIPSCANLIB)" = "libfips" ]; then \
+ $(ARD) libcrypto.a fipscanister.o ; \
+- $(MAKE) SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \
++ $(MAKE) -e SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \
+ $(AR) libcrypto.a fips/fipscanister.o ; \
+ else \
+ if [ "$(FIPSCANLIB)" = "libcrypto" ]; then \
+@@ -373,7 +373,7 @@ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+ shlibdeps=-lcrypto; \
+ [ "$(FIPSCANLIB)" = "libfips" ] && shlibdeps="$$shlibdeps -lfips"; \
+- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \
++ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2 ; \
+ exit 1; \
+diff --git a/crypto/Makefile b/crypto/Makefile
+index 6557f2b..a69bf7c 100644
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -103,7 +103,7 @@ $(LIB): $(LIBOBJ)
+
+ shared: buildinf.h lib subdirs
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ libs:
+diff --git a/ssl/Makefile b/ssl/Makefile
+index 5ac3507..77ea2bd 100644
+--- a/ssl/Makefile
++++ b/ssl/Makefile
+@@ -62,7 +62,7 @@ lib: $(LIBOBJ)
+
+ shared: lib
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ files: