summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iw/iw_5.0.1.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2019-04-11 21:26:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-15 11:53:03 +0100
commite1bc9b8d25365fbf3e5f7546c8dd2db7bef704b2 (patch)
tree5cfbc2f9cd58f3587886c0a77d703c8845069007 /meta/recipes-connectivity/iw/iw_5.0.1.bb
parent64d1a8be539c003d920b33fd1ae1846da5bd99f9 (diff)
downloadopenembedded-core-contrib-e1bc9b8d25365fbf3e5f7546c8dd2db7bef704b2.tar.gz
iw: upgrade 4.14 -> 5.0.1
Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/iw/iw_5.0.1.bb')
-rw-r--r--meta/recipes-connectivity/iw/iw_5.0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/iw/iw_5.0.1.bb b/meta/recipes-connectivity/iw/iw_5.0.1.bb
new file mode 100644
index 0000000000..e127963513
--- /dev/null
+++ b/meta/recipes-connectivity/iw/iw_5.0.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
+DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
+wireless devices. It supports almost all new drivers that have been added \
+to the kernel recently. "
+HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
+SECTION = "base"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
+
+DEPENDS = "libnl"
+
+SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
+ file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
+ file://separate-objdir.patch \
+"
+
+SRC_URI[md5sum] = "a0a17ab1b20132c716bba9a4f9974ba6"
+SRC_URI[sha256sum] = "36fc7592dde7bec934df83cd53ef1f2c08ceec5cd58d07eb8f71cc6e8464013c"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "\
+ -f '${S}/Makefile' \
+ \
+ 'PREFIX=${prefix}' \
+ 'SBINDIR=${sbindir}' \
+ 'MANDIR=${mandir}' \
+"
+B = "${WORKDIR}/build"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}