aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-09-19 10:19:41 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-21 09:24:00 +0100
commit73afabf8e69019f08b424a06f3eafaab052b0606 (patch)
tree9ac18f003feac812a53e42af8de720c96e573863 /meta/recipes-bsp
parent817210ef57729bf0f3010328270ea4b954dfebcf (diff)
downloadopenembedded-core-contrib-73afabf8e69019f08b424a06f3eafaab052b0606.tar.gz
u-boot-fw-utils: Fix cross and target builds
- The environment tools target has change to envtools; - The HOSTCC variable must be used to set CC for cross; - Drop ARCH variable as it is set on config; Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
index c2e8f0fb84..02887a138a 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
@@ -5,13 +5,13 @@ DEPENDS = "mtd-utils"
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
-EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
do_compile () {
oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
+ oe_runmake envtools
}
do_install () {