aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-02 01:55:16 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:33:19 +0100
commit5fd4453d827fd7f5d4eec9292d61d532d074992e (patch)
tree98838c516748edd426a2ad4bd253642ae982169b /meta/recipes-bsp
parent9ee62f1da39024ff8941665eba1440faac691582 (diff)
downloadopenembedded-core-contrib-5fd4453d827fd7f5d4eec9292d61d532d074992e.tar.gz
grub-efi: add PACKAGECONFIG for grub-mount and device-mapper
We had PACKAGECONFIGs for grub_2.00 and grub_git, we also need them for grub-efi, otherwise there might be failures as: grub-2.00/util/grub-mount.c:37:23: fatal error: fuse/fuse.h: No such file or directory (From OE-Core rev: a7fca64d04949e76805e7acc3f617a1cd4a107a7) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub2.inc4
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb4
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb4
3 files changed, 4 insertions, 8 deletions
diff --git a/meta/recipes-bsp/grub/grub2.inc b/meta/recipes-bsp/grub/grub2.inc
index 39469576cc..4d9e3c7287 100644
--- a/meta/recipes-bsp/grub/grub2.inc
+++ b/meta/recipes-bsp/grub/grub2.inc
@@ -35,6 +35,10 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
inherit autotools gettext texinfo
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
+PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
+
# grub and grub-efi's sysroot/${datadir}/grub/grub-mkconfig_lib are
# conflicted, remove it since no one uses it.
SYSROOT_PREPROCESS_FUNCS_class-target += "remove_sysroot_mkconfig_lib"
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
index a11e960fe5..88a709edb6 100644
--- a/meta/recipes-bsp/grub/grub_2.00.bb
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -6,10 +6,6 @@ PR = "r1"
FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug"
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
-PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
-
EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
--enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 3ab675b298..c2760c9ace 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -20,10 +20,6 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
inherit autotools gettext texinfo
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
-PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
-
# configure.ac has code to set this automagically from the target tuple
# but the OE freeform one (core2-foo-bar-linux) don't work with that.