aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-04-17 21:30:12 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:37:46 +0100
commitdf755db584d3a17505700965591eccb68695d00d (patch)
tree5ab35e13e07bdda696909b31ab73c5ec6d414246 /meta/recipes-bsp
parentf06a276b7bd10f3ada796f943e7b702283da91eb (diff)
downloadopenembedded-core-contrib-df755db584d3a17505700965591eccb68695d00d.tar.gz
grub-efi: add grub target and image for aarch64
Add missing target and image for aarch64, as the current revision is already fully compatible with ARMv8. (From OE-Core rev: 43dc32aa00c87f62dcf9a857d4e32469ce27c9e9) Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.02.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.02.bb b/meta/recipes-bsp/grub/grub-efi_2.02.bb
index ed27b90fdb..7bfc8eece4 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.02.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.02.bb
@@ -22,6 +22,9 @@ python __anonymous () {
elif re.match('i.86', target):
grubtarget = 'i386'
grubimage = prefix + "bootia32.efi"
+ elif re.match('aarch64', target):
+ grubtarget = 'arm64'
+ grubimage = prefix + "bootaa64.efi"
else:
raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
d.setVar("GRUB_TARGET", grubtarget)