summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2020-08-17 11:32:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-18 11:43:32 +0100
commit02d55cd35aac15095fc44f0cf8f9e7a71638f485 (patch)
tree525855261de3986a39c62ad8408835d8cb4424cf /meta/recipes-bsp
parent5e7dc0d68efb2d43bbd5b1be9e6d555fc4456fb6 (diff)
downloadopenembedded-core-contrib-02d55cd35aac15095fc44f0cf8f9e7a71638f485.tar.gz
libubootenv: uprev to v0.3
Update libubootenv to the latest 0.3 release, which comprises the following commits: ``` 1efed83 Increase max length for device name 6f4fc1c uboot_env: Use canonicalized pathname when reading device 23b3086 Fix bug introduced by commit 52a70114 ed1a53e Dont store to device if no value changes 4a0a466 Merge pull request #7 from TomzBench/cmake-fix 6117831 Added Coverity badge 49372a1 Fix coverity #293496 69a6819 Fix coverity #293503 and #293507 258bf52 Fix coverity #293501 aa52e61 Fix coverity #293505 52a7011 Fix coverity #293504 and #293506 e822218 Fix coverity #293495 and #293497 23b305f Fix coverity #293499 25ef1f6 Add coverity setup for Travis 41b5188 fixed install for static target, fixed BUILD_DOC acknowledgement 86bd30a Restore ability to feed script file via stdin, using `-s -`. c91dcca ubi, write: fix invalid envsize ptr to UBI_IOCVOLUP f4b9cde Allow negative offsets 45bf92a Detect sector size if not found in config 9f59db6 uboot_env: remove unused variables 65d243e README: libubootenv is now in oe-core ba952d0 BUG: variable lists not released in close() 690f868 Variables are not removed when loading from file 9e3586a Make sure there's no file descriptor leakage in case of error 03647c4 Check config file defines a non-zero Sector size 3b2d4f1 Check environment size from fw_env.config 879c073 Do not hardcode path for install d9c639b libubootenv: add pkg-config support cc628ee libuboot: wrap libuboot in extern "C" for C++ ``` Also add u-boot-default-env to RRECOMMENDS since /etc/u-boot-initial-env is being referred in libubootenv source, and turns libubootenv's PACKAGE_ARCH to be MACHINE_ARCH since u-boot-default-env is a machine-arch package. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/libubootenv_0.3.bb (renamed from meta/recipes-bsp/u-boot/libubootenv_0.2.bb)7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-bsp/u-boot/libubootenv_0.2.bb b/meta/recipes-bsp/u-boot/libubootenv_0.3.bb
index 3820ba262e..47e64f9114 100644
--- a/meta/recipes-bsp/u-boot/libubootenv_0.2.bb
+++ b/meta/recipes-bsp/u-boot/libubootenv_0.3.bb
@@ -10,9 +10,8 @@ LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
SECTION = "libs"
-PV = "0.2+git${SRCPV}"
SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
-SRCREV = "86bd30a14e153a18f670b25708795253d8736f0f"
+SRCREV = "ad253cfdb07c8492f2ee46a52fbc607ad0b96414"
S = "${WORKDIR}/git"
@@ -24,4 +23,8 @@ DEPENDS = "zlib"
PROVIDES += "u-boot-fw-utils"
RPROVIDES_${PN}-bin += "u-boot-fw-utils"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RRECOMMENDS_${PN}-bin_append_class-target = " u-boot-default-env"
+
BBCLASSEXTEND = "native"