aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@tycoint.com>2017-09-21 12:25:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-25 14:14:03 +0100
commit7da4c0a56eb2027b3e36b9e42f1f83dfb02bb920 (patch)
treef807b5f8e0088d3cf2d70f39bed7f04506223a12 /meta/recipes-bsp
parentf044567326988e84e5d72040e9387c3240836ddb (diff)
downloadopenembedded-core-contrib-7da4c0a56eb2027b3e36b9e42f1f83dfb02bb920.tar.gz
Revert "u-boot: fix extlinux creation race"
This reverts commit 60c90398580998b2379bb438f0f75b29285135a5. This causes circular dependencies when UBOOT_SIGN_ENABLE is active. These are usually caused by circular dependencies and any circular dependency chains found will be printed below. Increase the debug level to see a list of unbuildable tasks. Identifying dependency loops (this may take a short while)... ERROR: Dependency loop #1 found: Task u-boot.bb:do_concat_dtb (dependent Tasks ['kernel.bb:do_assemble_fitimage']) Task u-boot.bb:do_install (dependent Tasks ['u-boot.bb:do_concat_dtb', 'pseudo_1.8.2.bb:do_populate_sysroot', 'u-boot.bb:do_compile']) Task u-boot.bb:do_deploy (dependent Tasks ['u-boot.bb:do_deploy_dtb', 'u-boot.bb:do_install']) Task .../recipes-kernel/linux/kernel.bb:do_assemble_fitimage (dependent Tasks ['kernel.bb:do_compile', 'u-boot.bb:do_deploy']) Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index aa21c0e556..c2bcf99840 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -304,4 +304,4 @@ do_deploy () {
fi
}
-addtask deploy before do_build after do_install
+addtask deploy before do_build after do_compile