aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-04-17 21:30:12 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:58 +0100
commit43dc32aa00c87f62dcf9a857d4e32469ce27c9e9 (patch)
treee46c5fcb01fb67f97f8ca3513f98e6e24eb7f27b /meta/recipes-bsp
parenta9d8a8b27fc4bc6bdaa9133efd87430813a13212 (diff)
downloadopenembedded-core-contrib-43dc32aa00c87f62dcf9a857d4e32469ce27c9e9.tar.gz
grub-efi: add grub target and image for aarch64
Add missing target and image for aarch64, as the current revision is already fully compatible with ARMv8. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.02.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.02.bb b/meta/recipes-bsp/grub/grub-efi_2.02.bb
index ed27b90fdb..7bfc8eece4 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.02.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.02.bb
@@ -22,6 +22,9 @@ python __anonymous () {
elif re.match('i.86', target):
grubtarget = 'i386'
grubimage = prefix + "bootia32.efi"
+ elif re.match('aarch64', target):
+ grubtarget = 'arm64'
+ grubimage = prefix + "bootaa64.efi"
else:
raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
d.setVar("GRUB_TARGET", grubtarget)