aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-26 11:00:39 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-26 11:01:49 +0100
commitdfa47303edeffa3f15f6cf53928fb9246b7c5d90 (patch)
treed5a4573e64879679070807c6302e644d74c945ee /meta/recipes-bsp
parentaebb9d6599aac683456adf56dc11f8b9f10f25c3 (diff)
downloadopenembedded-core-contrib-dfa47303edeffa3f15f6cf53928fb9246b7c5d90.tar.gz
qemu-config: add runtime dep on dbus-x11
dbus-launch moved into the dbus-x11 packages, so we need to drag it in. Also reorder fields to better fit with the styleguide Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index e74f2dab46..f91875e74e 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -3,8 +3,9 @@ DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
-RDEPENDS_${PN} = "distcc task-core-nfs-server oprofileui-server rsync bash"
-PR = "r19"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
+
+PR = "r20"
SRC_URI = "file://distcc.sh \
file://anjuta-remote-run \
@@ -15,9 +16,6 @@ SRC_URI = "file://distcc.sh \
S = "${WORKDIR}"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
-PACKAGE_ARCH = "all"
-
do_install() {
install -d ${D}${sysconfdir}/profile.d
@@ -34,6 +32,9 @@ do_install() {
install qemu-autostart ${D}/etc/init.d/
}
+RDEPENDS_${PN} = "distcc dbus-x11 task-core-nfs-server oprofileui-server rsync bash"
+PACKAGE_ARCH = "all"
+
inherit update-rc.d
INITSCRIPT_NAME = "qemu-autostart"