aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-08-09 15:12:32 +0800
committerSaul Wold <sgw@linux.intel.com>2013-08-13 10:13:18 -0700
commit883b1b396328e6cd67dcb4ca6fd8975b6e716c0a (patch)
treeda922d606142402b2027023862faf4d9b1f6cb61 /meta/recipes-bsp
parent6386dc718f85210c9b6b9f69878ec9a7847b78de (diff)
downloadopenembedded-core-contrib-883b1b396328e6cd67dcb4ca6fd8975b6e716c0a.tar.gz
grub_0.97: Fix to correctly ship files under /usr/lib
The grub_fix_for_automake-1.12.patch replaced pkglib with pkgdata to make grub_0.97 build with automake-1.12. However, it forgot to set up the pkgdatadir, thus causing grub_0.97 not shipping files under /usr/lib. This in turn resulted in an unworkable grub. This patch fixes this problem by setting up the pkgdatadir correctly. [YOCTO #4997] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub-0.97/grub_fix_for_automake-1.12.patch50
1 files changed, 38 insertions, 12 deletions
diff --git a/meta/recipes-bsp/grub/grub-0.97/grub_fix_for_automake-1.12.patch b/meta/recipes-bsp/grub/grub-0.97/grub_fix_for_automake-1.12.patch
index 97ee0ad225..0cf7dc96d7 100644
--- a/meta/recipes-bsp/grub/grub-0.97/grub_fix_for_automake-1.12.patch
+++ b/meta/recipes-bsp/grub/grub-0.97/grub_fix_for_automake-1.12.patch
@@ -1,4 +1,6 @@
-Upstream-Status: Pending
+Upstream-Status: Inappropriate
+
+Subject: [PATCH] grub: fix for automake-1.12
automake 1.12 has depricated automatic de-ANSI-fication support
@@ -10,25 +12,37 @@ this patch avoids these kinds of errors:
| autoreconf: automake failed with exit status: 1
| ERROR: autoreconf execution failed.
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-2012/05/04
+The upstream status is marked as 'Inappropriate' because this problem is not uncommon,
+it has been there for a long time and no change in upstream.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Index: grub-0.97/stage1/Makefile.am
===================================================================
---- grub-0.97.orig/stage1/Makefile.am
-+++ grub-0.97/stage1/Makefile.am
-@@ -1,5 +1,5 @@
- pkglibdir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
+--- a/stage1/Makefile.am
++++ b/stage1/Makefile.am
+@@ -1,7 +1,7 @@
+-pkglibdir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
-nodist_pkglib_DATA = stage1
++pkgdatadir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
+nodist_pkgdata_DATA = stage1
- CLEANFILES = $(nodist_pkglib_DATA)
+-CLEANFILES = $(nodist_pkglib_DATA)
++CLEANFILES = $(nodist_pkgdata_DATA)
+ # We can't use builtins or standard includes.
+ AM_CCASFLAGS = $(STAGE1_CFLAGS) -fno-builtin -nostdinc
Index: grub-0.97/stage2/Makefile.am
===================================================================
---- grub-0.97.orig/stage2/Makefile.am
-+++ grub-0.97/stage2/Makefile.am
-@@ -32,7 +32,7 @@ pkglibdir = $(libdir)/$(PACKAGE)/$(host_
+--- a/stage2/Makefile.am
++++ b/stage2/Makefile.am
+@@ -27,12 +27,12 @@ libgrub_a_CFLAGS = $(GRUB_CFLAGS) -I$(top_srcdir)/lib \
+ -DUSE_MD5_PASSWORDS=1 -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1
+
+ # Stage 2 and Stage 1.5's.
+-pkglibdir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
++pkgdatadir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
+
EXTRA_PROGRAMS = nbloader.exec pxeloader.exec diskless.exec
if DISKLESS_SUPPORT
@@ -37,7 +51,7 @@ Index: grub-0.97/stage2/Makefile.am
ffs_stage1_5 iso9660_stage1_5 jfs_stage1_5 minix_stage1_5 \
reiserfs_stage1_5 ufs2_stage1_5 vstafs_stage1_5 xfs_stage1_5 \
nbgrub pxegrub
-@@ -43,7 +43,7 @@ noinst_PROGRAMS = pre_stage2.exec start.
+@@ -43,7 +43,7 @@ noinst_PROGRAMS = pre_stage2.exec start.exec start_eltorito.exec \
reiserfs_stage1_5.exec ufs2_stage1_5.exec vstafs_stage1_5.exec \
xfs_stage1_5.exec nbloader.exec pxeloader.exec diskless.exec
else
@@ -46,3 +60,15 @@ Index: grub-0.97/stage2/Makefile.am
ffs_stage1_5 iso9660_stage1_5 jfs_stage1_5 minix_stage1_5 \
reiserfs_stage1_5 ufs2_stage1_5 vstafs_stage1_5 xfs_stage1_5
noinst_DATA = pre_stage2 start start_eltorito
+@@ -105,7 +105,7 @@ else
+ BUILT_SOURCES = stage2_size.h
+ endif
+
+-CLEANFILES = $(pkglib_DATA) $(noinst_DATA) $(BUILT_SOURCES)
++CLEANFILES = $(pkgdata_DATA) $(noinst_DATA) $(BUILT_SOURCES)
+
+ stage2_size.h: pre_stage2
+ -rm -f stage2_size.h
+--
+1.7.9.5
+