aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-07-11 17:03:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:09:29 +0100
commit71309a5c91209d4afaee874889fa7eefb266185f (patch)
tree65f702a6af4d574eca359b205070e3b311ce5f00 /meta/recipes-bsp
parentc258379181a438cb01728d223b3d05e0ab205941 (diff)
downloadopenembedded-core-contrib-71309a5c91209d4afaee874889fa7eefb266185f.tar.gz
u-boot: Add missing dependency on flex and bison native
The U-Boot build, in particular the Kconfig, depends on bison and flex native. Add the missing dependencies. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Alexander Kanavin <alexander.kanavin@linux.intel.com> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-common_2018.05.inc1
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb2
3 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-common_2018.05.inc b/meta/recipes-bsp/u-boot/u-boot-common_2018.05.inc
index 61566f5856..deec6e4890 100644
--- a/meta/recipes-bsp/u-boot/u-boot-common_2018.05.inc
+++ b/meta/recipes-bsp/u-boot/u-boot-common_2018.05.inc
@@ -1,5 +1,6 @@
HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
SECTION = "bootloaders"
+DEPENDS += "flex-native bison-native"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
index 02887a138a..52c13e75d8 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
@@ -1,7 +1,7 @@
require u-boot-common_${PV}.inc
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-DEPENDS = "mtd-utils"
+DEPENDS += "mtd-utils"
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
index 1c008be96e..08bff1d161 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
@@ -1,7 +1,7 @@
require u-boot-common_${PV}.inc
SUMMARY = "U-Boot bootloader image creation tool"
-DEPENDS = "openssl"
+DEPENDS += "openssl"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'