summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-22 17:54:57 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 17:08:28 +0000
commit14ee34e85f2b4768fb4488f8e708e678b0e23d5d (patch)
treef6e09001178cf3f3d8f6aca37d41bbeca1d87a6d /meta/recipes-bsp
parentfd551c5ad4c82f295470f278c524d55562a67a28 (diff)
downloadopenembedded-core-contrib-14ee34e85f2b4768fb4488f8e708e678b0e23d5d.tar.gz
u-boot-mkimage: Add dependency on dtc
The dtc is used when generating images which use Device Tree and we must use the OE version to avoid relying on the host one. Reported-by: Renato Caldas <rm.santos.caldas@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb
index f1fc564492..1c008be96e 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb
@@ -24,4 +24,6 @@ do_install () {
ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
+RDEPENDS_${PN} += "dtc"
+
BBCLASSEXTEND = "native nativesdk"