aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.10.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-08-13 23:07:07 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-03 15:05:42 +0800
commit3475b5f7559f3beaaff3391676363b4f6701fb28 (patch)
tree8c29db58a99c0227651925f003e5c129061257b9 /meta/recipes-bsp/v86d/v86d_0.1.10.bb
parent5b69128ecd77d9aaab5fa45752e908d375b79356 (diff)
downloadopenembedded-core-contrib-3475b5f7559f3beaaff3391676363b4f6701fb28.tar.gz
v86d: set INHIBIT_UPDATERCD_BBCLASS if 'sysvinit' not in DISTRO_FEATURES
Set INHIBIT_UPDATERCD_BBCLASS to "1" if 'sysvinit' is not in DISTRO_FEATURES. The functionality of the init script 'fbsetup' is implemented internally in systemd. So fbsetup is not installed if 'sysvinit' is in DISTRO_FEATURES. That's why we need to set INHIBIT_UPDATERCD_BBCLASS to "1" to avoid generation of update-rc.d related preinst/postinst scripts. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.10.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index 08438bea47..7ccb4ee30f 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -49,4 +49,11 @@ do_install () {
fi
}
+# As the recipe doesn't inherit systemd.bbclass, we need to set this variable
+# manually to avoid unnecessary postinst/preinst generated.
+python __anonymous() {
+ if not bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d):
+ d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
+}
+
inherit update-rc.d