aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-05-16 22:14:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 11:25:03 +0100
commit8e8cea4569ffa8ea81b7e99f98f9dab203614d22 (patch)
tree3ff9e855a238ff563445276847582b22312427bb /meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
parentdea59aab5d785d4f892cc26a8ea06eb4a6c554b3 (diff)
downloadopenembedded-core-contrib-8e8cea4569ffa8ea81b7e99f98f9dab203614d22.tar.gz
u-boot: Upgrade to 2018.05 release
This upgrades the U-Boot from 2018.03 to 2018.05 release. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
new file mode 100644
index 0000000000..1c008be96e
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.05.bb
@@ -0,0 +1,29 @@
+require u-boot-common_${PV}.inc
+
+SUMMARY = "U-Boot bootloader image creation tool"
+DEPENDS = "openssl"
+
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
+EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
+EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+
+ # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
+ # generating it requires bin2header tool, which for target build
+ # is built with target tools and thus cannot be executed on host.
+ sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
+
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+RDEPENDS_${PN} += "dtc"
+
+BBCLASSEXTEND = "native nativesdk"