aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-09-04 12:50:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-08 10:26:14 +0000
commit7f5f8bec25bc05acb7b6584e41e1067107b216dc (patch)
treef202443fd07ef51a84d535b1fe7af5b2a25ce8ca /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
parentc4d276f9f639a1a534789de12a4783ae931e6aa4 (diff)
downloadopenembedded-core-contrib-7f5f8bec25bc05acb7b6584e41e1067107b216dc.tar.gz
u-boot: Update to 2016.09.01 release
Upgrade U-Boot to the latest version. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
new file mode 100644
index 0000000000..5025961f91
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.09.01.bb
@@ -0,0 +1,19 @@
+require u-boot-common_${PV}.inc
+
+SUMMARY = "U-Boot bootloader image creation tool"
+DEPENDS = "openssl"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"