aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-03-18 15:39:34 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 22:57:59 +0000
commit15130f7bad0f0a1894c34bbb34a547722552c69e (patch)
treef2ffcf54c20e253756ba35c4652fcbfc77712b3d /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
parentc2450e4fd01487aaf5bb37a4c70a5397650ba5f8 (diff)
downloadopenembedded-core-contrib-15130f7bad0f0a1894c34bbb34a547722552c69e.tar.gz
u-boot: Upgrade to 2016.03 release
The 2016.03 release has been announced in March 14th. This incorporates a lot of bug fixes and improvements which are useful for any new embedded development. Along with the upgrade of U-Boot and its related recipes, this patch also drops the AM335x environment fix which has been merged into the release. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
new file mode 100644
index 0000000000..d5921a0443
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2016.03"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
+
+PV = "v2016.03+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"