aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-11-10 09:01:42 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:48:14 +0000
commitaebd1a87bbf960e69301bd29137aabb5dfab05fc (patch)
tree8cb518b966f6c9a4c3c4789d2deecf8e28514365 /meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
parent273eee7a3614caea17c5bc93b720353641293cf7 (diff)
downloadopenembedded-core-contrib-aebd1a87bbf960e69301bd29137aabb5dfab05fc.tar.gz
u-boot: Update to 2015.10 release
The U-Boot 2015.10 has been released at October 20th 2015. This also removes the GCC workaround, for the inline behavior, as this version properlu supports the GCC 5.2 as compiler. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
new file mode 100644
index 0000000000..301b6e2bec
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.10.bb
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2015.10"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "5ec0003b19cbdf06ccd6941237cbc0d1c3468e2d"
+
+PV = "v2015.10+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"