aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 11:10:30 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-22 23:25:00 +0100
commit3157f8995e24f8a70492a261815be3a6fe51dcbd (patch)
treebb1bdb2211476523b8e561478ffb588afed3f7c1 /meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
parent55851c6f389cb027496c96f6e0609c8892032e4d (diff)
downloadopenembedded-core-contrib-3157f8995e24f8a70492a261815be3a6fe51dcbd.tar.gz
u-boot: Upgrade to 2015.07 release
This upgrades the U-Boot and its related recipes for the 2015.07 release. The following recipes has been upgraded: - u-boot - u-boot-mkimage - u-boot-fw-utils The patches which were applied on top of the 2015.01 release are dropped as those are not needed in this release. The license checksum update was due minimal changes in the text, those have no impact in the license terms. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
new file mode 100644
index 0000000000..ba29bbb922
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2015.07.bb
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2015.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "33711bdd4a4dce942fb5ae85a68899a8357bdd94"
+
+PV = "v2015.07+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"