aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-04-09 01:02:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:57 +0100
commitc1d680326cabd10d0940827e8dfdc884f67b1e9a (patch)
tree888cf08b9920a0afad98da86fc7e87615bb60f51 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb
parentfb8ca4225f3e26bfc46cf6c06d55df72684c47c6 (diff)
downloadopenembedded-core-contrib-c1d680326cabd10d0940827e8dfdc884f67b1e9a.tar.gz
u-boot: Upgrade to 2018.03 release
This upgrades the U-Boot from 2018.01 to 2018.03 release and drops patches accepted upstream, getting the patch count to zero. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Ross Burton <ross.burton@intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb
new file mode 100644
index 0000000000..02887a138a
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.03.bb
@@ -0,0 +1,34 @@
+require u-boot-common_${PV}.inc
+
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+DEPENDS = "mtd-utils"
+
+INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake envtools
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
+
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"