aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-25 16:28:07 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-25 22:04:06 +0100
commite6a6f2fb4bae146fc3077f782090e91904e00a08 (patch)
tree69b150b4ebd454cf9720b4e30ed788976c479887 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
parentd3db94fe50c0da90d751112a083a39c872030897 (diff)
downloadopenembedded-core-contrib-e6a6f2fb4bae146fc3077f782090e91904e00a08.tar.gz
u-boot-fw-utils: update 2012.04 to 2012.04.01 release
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
new file mode 100644
index 0000000000..fe3422a2cb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2012.04.01.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+
+DEPENDS = "mtd-utils"
+
+# This is needs to be validated among supported BSP's before we can
+# make it default
+DEFAULT_PREFERENCE = "-1"
+
+# This revision corresponds to the tag "v2012.04.01"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
+
+PV = "v2012.04.01+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}"'
+
+do_compile () {
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}