summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-configure.inc
diff options
context:
space:
mode:
authorZev Weiss <zev@bewilderbeest.net>2022-01-18 22:48:12 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-20 11:57:24 +0000
commite55e6fb4983a41f74c0e457bf54bd8dfa5608daa (patch)
treefe8dd27e79722abb919d0cb7ad1a059afdbae8d4 /meta/recipes-bsp/u-boot/u-boot-configure.inc
parent420191dc951f04b36645ffae2d946b50150feab0 (diff)
downloadopenembedded-core-contrib-e55e6fb4983a41f74c0e457bf54bd8dfa5608daa.tar.gz
u-boot: Split do_configure logic into separate file
Some auxiliary u-boot recipes may need u-boot properly configured (including *.cfg additions via bbappends) but aren't necessarily building u-boot itself; to support such situations, here we split the u-boot do_configure() out of u-boot.inc and into its own u-boot-configure.inc. Signed-off-by: Zev Weiss <zev@bewilderbeest.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-configure.inc')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-configure.inc39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-configure.inc b/meta/recipes-bsp/u-boot/u-boot-configure.inc
new file mode 100644
index 0000000000..04e0894752
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-configure.inc
@@ -0,0 +1,39 @@
+# This provides the logic for creating the desired u-boot config,
+# accounting for any *.cfg files added to SRC_URI. It's separated
+# from u-boot.inc for use by recipes that need u-boot properly
+# configured but aren't doing a full build of u-boot itself (such as
+# its companion tools).
+
+inherit uboot-config cml1
+
+DEPENDS += "kern-tools-native"
+
+do_configure () {
+ if [ -n "${UBOOT_CONFIG}" ]; then
+ unset i j
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]; then
+ oe_runmake -C ${S} O=${B}/${config} ${config}
+ if [ -n "${@' '.join(find_cfgs(d))}" ]; then
+ merge_config.sh -m -O ${B}/${config} ${B}/${config}/.config ${@" ".join(find_cfgs(d))}
+ oe_runmake -C ${S} O=${B}/${config} oldconfig
+ fi
+ fi
+ done
+ unset j
+ done
+ unset i
+ DEVTOOL_DISABLE_MENUCONFIG=true
+ else
+ if [ -n "${UBOOT_MACHINE}" ]; then
+ oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
+ else
+ oe_runmake -C ${S} O=${B} oldconfig
+ fi
+ merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
+ cml1_do_configure
+ fi
+}