aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/qemu-config
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-18 00:03:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-31 12:56:38 +0100
commit26e5e5feb695864b11e47e24017e254c28f14494 (patch)
tree754537dc0577fdcb6cf753bfbd926aeb74183789 /meta/recipes-bsp/qemu-config
parent5c3f39c56d1a7402c1f1f3b6db1f2764fcc8f190 (diff)
downloadopenembedded-core-contrib-26e5e5feb695864b11e47e24017e254c28f14494.tar.gz
Improve handling of 'all' architecture recipes and their interaction with sstate
The existing PACKAGE_ARCH = "all" mechanism of sharing packages is problematic with sstate since there are a variety of variables which have target specific values and the sstate package therefore correctly changes signature depending on the MACHINE setting. This patch creates a new "allarch" class which sets: PACKAGE_ARCH = "all" (as per the existing convention) INHIBIT_DEFAULT_DEPS = "1" (since its not target specific and therefore can't depend on the cross compiler or target libc) TARGET_ARCH = "all" TARGET_OS = "linux" TARGET_CC_ARCH = "none" (since these variables shouldn't change between the different packages and target compiler flags shouldn't be getting used) PACKAGE_EXTRA_ARCHS = "" (since we shouldn't be depending on any architecture specific package architectures) Not all PACKAGE_ARCH = "all" recipes can use this class since some run configure checks on the compiler. This means they have target specific components and therefore the "all" classification is incorrect. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/qemu-config')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index f91875e74e..70a113e8dc 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
-PR = "r20"
+PR = "r21"
SRC_URI = "file://distcc.sh \
file://anjuta-remote-run \
@@ -33,9 +33,8 @@ do_install() {
}
RDEPENDS_${PN} = "distcc dbus-x11 task-core-nfs-server oprofileui-server rsync bash"
-PACKAGE_ARCH = "all"
-inherit update-rc.d
+inherit update-rc.d allarch
INITSCRIPT_NAME = "qemu-autostart"
INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."