aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/gummiboot/gummiboot_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-09-09 08:24:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-21 15:39:35 +0100
commit2593dc1936d7e477769753b8c8f97b988ecc8823 (patch)
treed83ca9c7ef366e7544ece4b4a5c9d42ec92d4954 /meta/recipes-bsp/gummiboot/gummiboot_git.bb
parentdb87b70b6422cea860b5ad688015e4b668ff605d (diff)
downloadopenembedded-core-contrib-2593dc1936d7e477769753b8c8f97b988ecc8823.tar.gz
gummiboot: Fix build warnings seen with gcc5
gummiboot uses -mno-sse so we should disble using sse for mfpmath as well Fix syntax errors in struct defines Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/gummiboot/gummiboot_git.bb')
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gummiboot/gummiboot_git.bb b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
index 91c3db9306..376ab542dd 100644
--- a/meta/recipes-bsp/gummiboot/gummiboot_git.bb
+++ b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -13,6 +13,7 @@ PV = "48+git${SRCPV}"
SRCREV = "2bcd919c681c952eb867ef1bdb458f1bc49c2d55"
SRC_URI = "git://anongit.freedesktop.org/gummiboot \
file://fix-objcopy.patch \
+ file://0001-console-Fix-C-syntax-errors-for-function-declaration.patch \
"
# Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi
@@ -28,6 +29,8 @@ EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
+TUNE_CCARGS_remove = "-mfpmath=sse"
+
do_deploy () {
install ${B}/gummiboot*.efi ${DEPLOYDIR}
}