aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-03-06 20:58:47 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 21:46:52 +0000
commita75ccaea77c8aad8d46e87e8ed4af2e2e0ad5327 (patch)
tree5ecfb3a947c6a0d9be4d96e18c0a6873a2b8962c /meta/recipes-bsp/grub
parent839d6f124c2761194c868cf5597e1aa96571e1ca (diff)
downloadopenembedded-core-contrib-a75ccaea77c8aad8d46e87e8ed4af2e2e0ad5327.tar.gz
meta: start to ignore the largefile distro feature
The largefile distro feature has been enabled by default in oe-core for a long time and, more recently, also in poky-tiny. Building without the largefile distro feature receives little or no testing. Many packages now enable LFS without exposing a configure option, so there should be very little expectation that disabling the distro feature will result in a distro which globally disables LFS. Respecting the distro feature adds a maintenance over-head and may be the source of configurations oddities (e.g. dbus-native currently builds with LFS disabled for no clear reason - fixed by this commit). Ignore the largefile distro feature more widely, as a first step towards deprecating and eventually removing it. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb6
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb6
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb6
3 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index e0503013fd..e12f1d773f 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -31,9 +31,9 @@ inherit deploy
CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
--enable-efiemu=no --program-prefix='' \
- --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
-
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
+ --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no \
+ --enable-largefile \
+"
# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
index 07e1d101b3..c3829381ae 100644
--- a/meta/recipes-bsp/grub/grub_2.00.bb
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -4,9 +4,9 @@ RDEPENDS_${PN} = "diffutils freetype grub-editenv"
PR = "r1"
EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
- --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
-
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
+ --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no \
+ --enable-largefile \
+"
PACKAGES =+ "grub-editenv"
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 27a5d1f123..0a81e530f4 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -27,9 +27,9 @@ GRUBPLATFORM_aarch64 = "efi"
GRUBPLATFORM ??= "pc"
EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
- --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
-
-EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
+ --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no \
+ --enable-largefile \
+"
do_install_append () {
install -d ${D}${sysconfdir}/grub.d