aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-01-24 13:33:15 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-31 14:40:19 +0000
commit26f4eb19b6e9c71374659605a01af762a0361f41 (patch)
tree9908ad3df8dc4251ad34511614a625063ceda7d7 /meta/recipes-bsp/grub
parent3378c322247f5c261f40d06480379da9a24e3082 (diff)
downloadopenembedded-core-contrib-26f4eb19b6e9c71374659605a01af762a0361f41.tar.gz
grub-efi: Deploy grub named efi binaries
This allows both grub and systemd-boot efi bootloaders to co-exisit Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/grub')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index 03d273dbd9..e0503013fd 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -16,10 +16,10 @@ python __anonymous () {
target = d.getVar('TARGET_ARCH')
if target == "x86_64":
grubtarget = 'x86_64'
- grubimage = "bootx64.efi"
+ grubimage = "grub-efi-bootx64.efi"
elif re.match('i.86', target):
grubtarget = 'i386'
- grubimage = "bootia32.efi"
+ grubimage = "grub-efi-bootia32.efi"
else:
raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
d.setVar("GRUB_TARGET", grubtarget)