aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.00.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-12 23:43:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 18:14:51 +0000
commita290429c8415042cb8c2f4258e76a3cc6815a172 (patch)
treea4c6c3bf5ca1f45679d97d7f47b854e97899f390 /meta/recipes-bsp/grub/grub_2.00.bb
parentaeee86050019caae5da3af8d31cf57bc811c5e80 (diff)
downloadopenembedded-core-contrib-a290429c8415042cb8c2f4258e76a3cc6815a172.tar.gz
grub: Backport fix for largefile detection/use
This is inspired by musl porting, where grub's configure is enabling largefile support based on glibc versions, instead an upstream patch turns it into autoconf check Update git version recipe arm platforms use this recipe to provide grub and it needed fixes from upstream so upgrade to latest tip of git and forward port patches as well as drop the ones already applied upstream Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
index c1be13304a..addc1b2833 100644
--- a/meta/recipes-bsp/grub/grub_2.00.bb
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -6,6 +6,8 @@ PR = "r1"
EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
--enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
}