summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.02.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-21 20:36:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-23 17:43:59 +0100
commit4f27e4042dfb39caa71c7c6eb0a327de6af4d563 (patch)
tree7e73801d21fc6a3d01345f17ecb713db520a1ef8 /meta/recipes-bsp/grub/grub-efi_2.02.bb
parent86009f82c8c8206cc79f68d14d68c7c0b3ffe491 (diff)
downloadopenembedded-core-contrib-4f27e4042dfb39caa71c7c6eb0a327de6af4d563.tar.gz
grub: Update to 2.02
Drop git recipe, add arm bits to 2.02 itself Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.02.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.02.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.02.bb b/meta/recipes-bsp/grub/grub-efi_2.02.bb
new file mode 100644
index 0000000000..9d494d5d12
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub-efi_2.02.bb
@@ -0,0 +1,69 @@
+require grub2.inc
+
+GRUBPLATFORM = "efi"
+
+DEPENDS_class-target = "grub-efi-native"
+RDEPENDS_${PN}_class-target = "diffutils freetype"
+
+SRC_URI += " \
+ file://cfg \
+ "
+
+S = "${WORKDIR}/grub-${PV}"
+
+# Determine the target arch for the grub modules
+python __anonymous () {
+ import re
+ target = d.getVar('TARGET_ARCH')
+ if target == "x86_64":
+ grubtarget = 'x86_64'
+ grubimage = "grub-efi-bootx64.efi"
+ elif re.match('i.86', target):
+ grubtarget = 'i386'
+ grubimage = "grub-efi-bootia32.efi"
+ else:
+ raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
+ d.setVar("GRUB_TARGET", grubtarget)
+ d.setVar("GRUB_IMAGE", grubimage)
+}
+
+inherit deploy
+
+CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
+EXTRA_OECONF += "--enable-efiemu=no"
+
+# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
+# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
+CFLAGS_append_class-native = " -Wno-error=trampolines"
+
+do_install_class-native() {
+ install -d ${D}${bindir}
+ install -m 755 grub-mkimage ${D}${bindir}
+}
+
+GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
+
+do_deploy() {
+ # Search for the grub.cfg on the local boot media by using the
+ # built in cfg file provided via this recipe
+ grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
+ -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
+ ${GRUB_BUILDIN}
+ install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
+}
+
+do_deploy_class-native() {
+ :
+}
+
+addtask deploy after do_install before do_build
+
+FILES_${PN} += "${libdir}/grub/${GRUB_TARGET}-efi \
+ ${datadir}/grub \
+ "
+
+# 64-bit binaries are expected for the bootloader with an x32 userland
+INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
+INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
+
+BBCLASSEXTEND = "native"