aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-12-14 21:13:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 08:30:03 +0000
commit7c552996597faaee2fbee185b250c0ee30ea3b5f (patch)
treebb74186da3e2d4b03c33875a71fbe340ba09a0d7 /meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
parent84ec50e587e7464b260b1b189659b93b6dab0ef6 (diff)
downloadopenembedded-core-contrib-7c552996597faaee2fbee185b250c0ee30ea3b5f.tar.gz
meta: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb')
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
index e0d8ee76dd..9ddc4ba716 100644
--- a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
@@ -27,7 +27,7 @@ COMPATIBLE_HOST_armv4 = 'null'
def gnu_efi_arch(d):
import re
- tarch = d.getVar("TARGET_ARCH", True)
+ tarch = d.getVar("TARGET_ARCH")
if re.match("i[3456789]86", tarch):
return "ia32"
return tarch