aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-08-20 12:24:43 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 13:00:06 +0100
commite76f76a37d046957f46814d9a106f0f5b4f8af72 (patch)
treecadd962b3cdc9e64cde697a8efa9f032371217f0 /meta/packages
parent70cd1ff43ff1109847cce2f2fe891fb9bdfdb3b2 (diff)
downloadopenembedded-core-contrib-e76f76a37d046957f46814d9a106f0f5b4f8af72.tar.gz
ftrace: add trace-cmd for ftrace control and config
Rather than manually configuring ftrace, trace-cmd was created to provide a more user friendly interface to the tracer. Some examples are: # ./trace-cmd record -e all ls /bin Then to see the information: # ./trace-cmd report To see just a subsystem: # ./trace-cmd record -e irq ls /bin To list the available trace events: # ./trace-cmd list -e You can also trace a single trace point with one of two methods: # ./trace-cmd record -e sched:sched_wakeup ls /bin Or simply: # ./trace-cmd record -e sched_wakeup ls /bin This tool also works with tracers (plugins) as well as events # ./trace-cmd list -p Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/trace-cmd/trace-cmd_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/packages/trace-cmd/trace-cmd_git.bb b/meta/packages/trace-cmd/trace-cmd_git.bb
new file mode 100644
index 0000000000..57d54d6683
--- /dev/null
+++ b/meta/packages/trace-cmd/trace-cmd_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "User interface to Ftrace"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "glibc"
+
+PR = r0
+PV = "1.0.4+git${SRCPV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git"
+S = "${WORKDIR}/git"
+
+
+do_compile() {
+ oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" prefix=${prefix}
+}
+
+do_install() {
+ oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" \
+ prefix=${prefix} DESTDIR=${D} install
+}