aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-08-27 22:34:19 +0000
committerRichard Purdie <richard@openedhand.com>2006-08-27 22:34:19 +0000
commit418c6e58f7c577302299831b90df620cd9485a3d (patch)
treec92e0c6efd1e729c9b7f336a89d42f1dfdf35695 /meta/packages
parentd717d4f196fdd2307d97d62197f45500e5e32289 (diff)
downloadopenembedded-core-contrib-418c6e58f7c577302299831b90df620cd9485a3d.tar.gz
avahi 0.6.10 -> 0.6.13 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@663 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/avahi/avahi_0.6.13.bb (renamed from meta/packages/avahi/avahi_0.6.10.bb)13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta/packages/avahi/avahi_0.6.10.bb b/meta/packages/avahi/avahi_0.6.13.bb
index 2a6eb24033..0898bf036c 100644
--- a/meta/packages/avahi/avahi_0.6.10.bb
+++ b/meta/packages/avahi/avahi_0.6.13.bb
@@ -12,7 +12,7 @@ RRECOMMENDS = "libnss-mdns"
SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
+PACKAGES =+ "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
@@ -37,17 +37,24 @@ CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
inherit autotools pkgconfig update-rc.d
+
+do_stage() {
+ autotools_stage_all
+}
+
INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+# At the time the postinst runs, dbus might not be setup so only restart if running
+
pkg_postinst_avahi-daemon () {
+ # can't do this offline
if [ "x$D" != "x" ]; then
exit 1
fi
-
grep avahi /etc/group || addgroup avahi
grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
@@ -58,8 +65,6 @@ pkg_postinst_avahi-daemon () {
fi
}
-# dbus errors to /dev/null as at the time the postinst runs, dbus might not be setup.
-
pkg_postrm_avahi-daemon () {
deluser avahi || true
delgroup avahi || true